$re = '/\$_(.*?)\[\'(.*?)\'\]/';
$str = '$_POST[\'INPUT\']';
$subst = "$this->\L$2->$1\('\U$2\')";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;