re = /\$_(.*?)\['(.*?)'\]/
str = '$_POST[\'INPUT\']'
subst = '$this->\\L$2->$1\\(\'\\U$2\\\')'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result