using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$_(.*?)\['(.*?)'\]";
string substitution = @"$this->\L$2->$1\('\U$2\')";
string input = @"$_POST['INPUT']";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}