#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)'[^']*'(*SKIP)(*F)|\s+"
Local $sString = "'01'" & @CRLF & _
"'01' '02'" & @CRLF & _
"#bateau" & @CRLF & _
"#bateau #batiment" & @CRLF & _
"#'autres 32'" & @CRLF & _
"#'autres 32' #'batiment 30'" & @CRLF & _
"#'autres 32' #'batiment 30' #'contenu 31'" "#'34'" & @CRLF & _
"#'34' #'33' #'35'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")