re = /'[^']*'(*SKIP)(*F)|\s+/m
str = '\'01\'
\'01\' \'02\'
#bateau
#bateau #batiment
#\'autres 32\'
#\'autres 32\' #\'batiment 30\'
#\'autres 32\' #\'batiment 30\' #\'contenu 31\'" "#\'34\'
#\'34\' #\'33\' #\'35\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end