import Foundation
let pattern = #"'[^']*'(*SKIP)(*F)|\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
'01'
'01' '02'
#bateau
#bateau #batiment
#'autres 32'
#'autres 32' #'batiment 30'
#'autres 32' #'batiment 30' #'contenu 31'" "#'34'
#'34' #'33' #'35'
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)