use strict;
my $str = '\'01\'
\'01\' \'02\'
#bateau
#bateau #batiment
#\'autres 32\'
#\'autres 32\' #\'batiment 30\'
#\'autres 32\' #\'batiment 30\' #\'contenu 31\'" "#\'34\'
#\'34\' #\'33\' #\'35\'';
my $regex = qr/'[^']*'(*SKIP)(*F)|\s+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}