import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'[^']*'(*SKIP)(*F)|\\s+";
final String string = "'01'\n"
+ "'01' '02'\n"
+ "#bateau\n"
+ "#bateau #batiment\n"
+ "#'autres 32'\n"
+ "#'autres 32' #'batiment 30'\n"
+ "#'autres 32' #'batiment 30' #'contenu 31'\" \"#'34'\n"
+ "#'34' #'33' #'35'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}