const regex = /'[^']*'(*SKIP)(*F)|\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'[^\']*\'(*SKIP)(*F)|\\s+', 'gm')
const str = `'01'
'01' '02'
#bateau
#bateau #batiment
#'autres 32'
#'autres 32' #'batiment 30'
#'autres 32' #'batiment 30' #'contenu 31'" "#'34'
#'34' #'33' #'35'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}