// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'[^']*'(*SKIP)(*F)|\s+").unwrap();
let string = "'01'
'01' '02'
#bateau
#bateau #batiment
#'autres 32'
#'autres 32' #'batiment 30'
#'autres 32' #'batiment 30' #'contenu 31'\" \"#'34'
#'34' #'33' #'35'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}