package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'[^']*'(*SKIP)(*F)|\s+`)
var str = `'01'
'01' '02'
#bateau
#bateau #batiment
#'autres 32'
#'autres 32' #'batiment 30'
#'autres 32' #'batiment 30' #'contenu 31'" "#'34'
#'34' #'33' #'35'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}