$re = '/\'[^\']*\'(*SKIP)(*F)|\s+/m';
$str = '\'01\'
\'01\' \'02\'
#bateau
#bateau #batiment
#\'autres 32\'
#\'autres 32\' #\'batiment 30\'
#\'autres 32\' #\'batiment 30\' #\'contenu 31\'" "#\'34\'
#\'34\' #\'33\' #\'35\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);