using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'[^']*'(*SKIP)(*F)|\s+";
string input = @"'01'
'01' '02'
#bateau
#bateau #batiment
#'autres 32'
#'autres 32' #'batiment 30'
#'autres 32' #'batiment 30' #'contenu 31'"" ""#'34'
#'34' #'33' #'35'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}