# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?\\/)\d+(?:(.*?\\/)\d+\b)?/$1$2/gm;t' <<< "/dev/user
/dev/user/123
/dev/user/123/inventory/4
/dev/server/3/statistics
"