#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*?\/)\d+(?:(.*?\/)\d+\b)?"
Local $sString = "/dev/user" & @CRLF & _
"/dev/user/123" & @CRLF & _
"/dev/user/123/inventory/4" & @CRLF & _
"/dev/server/3/statistics" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)