$re = '/^(.*?\/)\d+(?:(.*?\/)\d+\b)?/m';
$str = '/dev/user
/dev/user/123
/dev/user/123/inventory/4
/dev/server/3/statistics
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;