re = /^(.*?\/)\d+(?:(.*?\/)\d+\b)?/m
str = '/dev/user
/dev/user/123
/dev/user/123/inventory/4
/dev/server/3/statistics
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result