use strict;
my $str = '/dev/user
/dev/user/123
/dev/user/123/inventory/4
/dev/server/3/statistics
';
my $regex = qr/^(.*?\/)\d+(?:(.*?\/)\d+\b)?/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";