using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?\/)\d+(?:(.*?\/)\d+\b)?";
string substitution = @"$1$2";
string input = @"/dev/user
/dev/user/123
/dev/user/123/inventory/4
/dev/server/3/statistics
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}