import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?\\/)\\d+(?:(.*?\\/)\\d+\\b)?";
final String string = "/dev/user\n"
+ "/dev/user/123\n"
+ "/dev/user/123/inventory/4\n"
+ "/dev/server/3/statistics\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}