import Foundation
let pattern = #"^(.*?\/)\d+(?:(.*?\/)\d+\b)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/dev/user
/dev/user/123
/dev/user/123/inventory/4
/dev/server/3/statistics
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)