package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?\/)\d+(?:(.*?\/)\d+\b)?`)
var str = `/dev/user
/dev/user/123
/dev/user/123/inventory/4
/dev/server/3/statistics
`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}