const regex = /^(.*?\/)\d+(?:(.*?\/)\d+\b)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?\\\/)\\d+(?:(.*?\\\/)\\d+\\b)?', 'gm')
const str = `/dev/user
/dev/user/123
/dev/user/123/inventory/4
/dev/server/3/statistics
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);