# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"(\s+)?([a-z\s]+?)(\s+)?"/$2/gm;t' <<< "\"name\",\"john\",\"name of john\"
\"name\",\" john\",\"name of john\"
\" name \",\" john\",\"name of john \"
\" name \",\" john\",\" name of john \""