const regex = /"(\s+)?([a-z\s]+?)(\s+)?"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(\\s+)?([a-z\\s]+?)(\\s+)?"', 'gm')
const str = `"name","john","name of john"
"name"," john","name of john"
" name "," john","name of john "
" name "," john"," name of john "`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);