// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"(\s+)?([a-z\s]+?)(\s+)?""#).unwrap();
let string = "\"name\",\"john\",\"name of john\"
\"name\",\" john\",\"name of john\"
\" name \",\" john\",\"name of john \"
\" name \",\" john\",\" name of john \"";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}