re = /"(\s+)?([a-z\s]+?)(\s+)?"/m
str = '"name","john","name of john"
"name"," john","name of john"
" name "," john","name of john "
" name "," john"," name of john "'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result