package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(\s+)?([a-z\s]+?)(\s+)?"`)
var str = `"name","john","name of john"
"name"," john","name of john"
" name "," john","name of john "
" name "," john"," name of john "`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}