$re = '/"(\s+)?([a-z\s]+?)(\s+)?"/m';
$str = '"name","john","name of john"
"name"," john","name of john"
" name "," john","name of john "
" name "," john"," name of john "';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;