use strict;
my $str = '"name","john","name of john"
"name"," john","name of john"
" name "," john","name of john "
" name "," john"," name of john "';
my $regex = qr/"(\s+)?([a-z\s]+?)(\s+)?"/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";