import re
regex = re.compile(r"\"(\s+)?([a-z\s]+?)(\s+)?\"", flags=re.MULTILINE)
test_str = ("\"name\",\"john\",\"name of john\"\n"
"\"name\",\" john\",\"name of john\"\n"
"\" name \",\" john\",\"name of john \"\n"
"\" name \",\" john\",\" name of john \"")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)