import Foundation
let pattern = #""(\s+)?([a-z\s]+?)(\s+)?""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"name","john","name of john"
"name"," john","name of john"
" name "," john","name of john "
" name "," john"," name of john "
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)