#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)(?(DEFINE)(?'nonbrace' [^{}\n] ))" & @CRLF & _
"(?(DEFINE)(?'begin' { ))" & @CRLF & _
"(?(DEFINE)(?'end' } ))" & @CRLF & _
"(?(DEFINE)(?'middle' (?&nonbrace) ))" & @CRLF & _
"(?(DEFINE)(?'nested'" & @CRLF & _
" ((?&begin)((?&middle)|(?&nested))*(?&end))" & @CRLF & _
"))" & @CRLF & _
"^((?&nonbrace)*+(?&nested))*+(?&nonbrace)*$"
Local $sString = "" & @CRLF & _
"a" & @CRLF & _
"abc" & @CRLF & _
"{}" & @CRLF & _
"{a}" & @CRLF & _
"{{aa}}" & @CRLF & _
"{a{b}}" & @CRLF & _
"{a{bb}a}" & @CRLF & _
"{a{b{c}b}a}" & @CRLF & _
"n{a{}}nn{b{bb}}" & @CRLF & _
"\@writefile{toc}}}}{\contentsline {section}{\numberline {B" & @CRLF & _
"\@writefile{toc}{\contentsline {section}{\numberline {B" & @CRLF & _
"Previous lines contain mismatched braces. This and the next line don't." & @CRLF & _
"\@writefile{toc}{\contentsline {section}{\numberline {B}}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")