re = /(?(DEFINE)(?'nonbrace' [^{}\n] ))
(?(DEFINE)(?'begin' { ))
(?(DEFINE)(?'end' } ))
(?(DEFINE)(?'middle' (?&nonbrace) ))
(?(DEFINE)(?'nested'
((?&begin)((?&middle)|(?&nested))*(?&end))
))
^((?&nonbrace)*+(?&nested))*+(?&nonbrace)*$/xm
str = '
a
abc
{}
{a}
{{aa}}
{a{b}}
{a{bb}a}
{a{b{c}b}a}
n{a{}}nn{b{bb}}
\\@writefile{toc}}}}{\\contentsline {section}{\\numberline {B
\\@writefile{toc}{\\contentsline {section}{\\numberline {B
Previous lines contain mismatched braces. This and the next line don\'t.
\\@writefile{toc}{\\contentsline {section}{\\numberline {B}}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end