using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?(DEFINE)(?'nonbrace' [^{}\n] ))
(?(DEFINE)(?'begin' { ))
(?(DEFINE)(?'end' } ))
(?(DEFINE)(?'middle' (?&nonbrace) ))
(?(DEFINE)(?'nested'
((?&begin)((?&middle)|(?&nested))*(?&end))
))
^((?&nonbrace)*+(?&nested))*+(?&nonbrace)*$";
string input = @"
a
abc
{}
{a}
{{aa}}
{a{b}}
{a{bb}a}
{a{b{c}b}a}
n{a{}}nn{b{bb}}
\@writefile{toc}}}}{\contentsline {section}{\numberline {B
\@writefile{toc}{\contentsline {section}{\numberline {B
Previous lines contain mismatched braces. This and the next line don't.
\@writefile{toc}{\contentsline {section}{\numberline {B}}}";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}