# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?(DEFINE)(?'nonbrace' [^{}\n] ))
(?(DEFINE)(?'begin' { ))
(?(DEFINE)(?'end' } ))
(?(DEFINE)(?'middle' (?&nonbrace) ))
(?(DEFINE)(?'nested'
((?&begin)((?&middle)|(?&nested))*(?&end))
))
^((?&nonbrace)*+(?&nested))*+(?&nonbrace)*$
"""
test_str = ("\n"
"a\n"
"abc\n"
"{}\n"
"{a}\n"
"{{aa}}\n"
"{a{b}}\n"
"{a{bb}a}\n"
"{a{b{c}b}a}\n"
"n{a{}}nn{b{bb}}\n"
"\\@writefile{toc}}}}{\\contentsline {section}{\\numberline {B\n"
"\\@writefile{toc}{\\contentsline {section}{\\numberline {B\n"
"Previous lines contain mismatched braces. This and the next line don't.\n"
"\\@writefile{toc}{\\contentsline {section}{\\numberline {B}}}")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.