import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)(?'nonbrace' [^\\{\\}\\n] ))\n"
+ "(?(DEFINE)(?'begin' \\{ ))\n"
+ "(?(DEFINE)(?'end' \\} ))\n"
+ "(?(DEFINE)(?'middle' (?&nonbrace) ))\n"
+ "(?(DEFINE)(?'nested'\n"
+ " ((?&begin)((?&middle)|(?&nested))*(?&end))\n"
+ "))\n"
+ "^((?&nonbrace)*+(?&nested))*+(?&nonbrace)*$";
final String string = "\n"
+ "a\n"
+ "abc\n"
+ "{}\n"
+ "{a}\n"
+ "{{aa}}\n"
+ "{a{b}}\n"
+ "{a{bb}a}\n"
+ "{a{b{c}b}a}\n"
+ "n{a{}}nn{b{bb}}\n"
+ "\\@writefile{toc}}}}{\\contentsline {section}{\\numberline {B\n"
+ "\\@writefile{toc}{\\contentsline {section}{\\numberline {B\n"
+ "Previous lines contain mismatched braces. This and the next line don't.\n"
+ "\\@writefile{toc}{\\contentsline {section}{\\numberline {B}}}";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}