// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?xm)(?(DEFINE)(?'nonbrace' [^{}\n] ))
(?(DEFINE)(?'begin' { ))
(?(DEFINE)(?'end' } ))
(?(DEFINE)(?'middle' (?&nonbrace) ))
(?(DEFINE)(?'nested'
((?&begin)((?&middle)|(?&nested))*(?&end))
))
^((?&nonbrace)*+(?&nested))*+(?&nonbrace)*$").unwrap();
let string = "
a
abc
{}
{a}
{{aa}}
{a{b}}
{a{bb}a}
{a{b{c}b}a}
n{a{}}nn{b{bb}}
\\@writefile{toc}}}}{\\contentsline {section}{\\numberline {B
\\@writefile{toc}{\\contentsline {section}{\\numberline {B
Previous lines contain mismatched braces. This and the next line don't.
\\@writefile{toc}{\\contentsline {section}{\\numberline {B}}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}