# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\d+\h+|\h+\d+$|(\h+\d+\h+)//gm;t' <<< "need 4 speed
shall become \"need speed\"
4 speed
shall become \"speed\"
speed 4
shall become \"speed\"
At the same time
4speed shall remain as it is
speed4
shall remain as it is
speed2car
shall remain as it is"