import Foundation
let pattern = #"^\d+\h+|\h+\d+$|(\h+\d+\h+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
need 4 speed
shall become "need speed"
4 speed
shall become "speed"
speed 4
shall become "speed"
At the same time
4speed shall remain as it is
speed4
shall remain as it is
speed2car
shall remain as it is
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)