$re = '/^\d+\h+|\h+\d+$|(\h+\d+\h+)/m';
$str = 'need 4 speed
shall become "need speed"
4 speed
shall become "speed"
speed 4
shall become "speed"
At the same time
4speed shall remain as it is
speed4
shall remain as it is
speed2car
shall remain as it is';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;