// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+\h+|\h+\d+$|(\h+\d+\h+)").unwrap();
let string = "need 4 speed
shall become \"need speed\"
4 speed
shall become \"speed\"
speed 4
shall become \"speed\"
At the same time
4speed shall remain as it is
speed4
shall remain as it is
speed2car
shall remain as it is";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}