#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d+\h+|\h+\d+$|(\h+\d+\h+)"
Local $sString = "need 4 speed" & @CRLF & _
"shall become "need speed"" & @CRLF & _
"" & @CRLF & _
"4 speed" & @CRLF & _
"shall become "speed"" & @CRLF & _
"" & @CRLF & _
"speed 4" & @CRLF & _
"shall become "speed"" & @CRLF & _
"" & @CRLF & _
"At the same time" & @CRLF & _
"" & @CRLF & _
"4speed shall remain as it is" & @CRLF & _
"" & @CRLF & _
"speed4" & @CRLF & _
"shall remain as it is" & @CRLF & _
"" & @CRLF & _
"speed2car" & @CRLF & _
"shall remain as it is"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)