const regex = /^\d+\h+|\h+\d+$|(\h+\d+\h+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+\\h+|\\h+\\d+$|(\\h+\\d+\\h+)', 'gm')
const str = `need 4 speed
shall become "need speed"
4 speed
shall become "speed"
speed 4
shall become "speed"
At the same time
4speed shall remain as it is
speed4
shall remain as it is
speed2car
shall remain as it is`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);