package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+\h+|\h+\d+$|(\h+\d+\h+)`)
var str = `need 4 speed
shall become "need speed"
4 speed
shall become "speed"
speed 4
shall become "speed"
At the same time
4speed shall remain as it is
speed4
shall remain as it is
speed2car
shall remain as it is`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}