use strict;
my $str = 'need 4 speed
shall become "need speed"
4 speed
shall become "speed"
speed 4
shall become "speed"
At the same time
4speed shall remain as it is
speed4
shall remain as it is
speed2car
shall remain as it is';
my $regex = qr/^\d+\h+|\h+\d+$|(\h+\d+\h+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";