using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\h+|\h+\d+$|(\h+\d+\h+)";
string substitution = @"";
string input = @"need 4 speed
shall become ""need speed""
4 speed
shall become ""speed""
speed 4
shall become ""speed""
At the same time
4speed shall remain as it is
speed4
shall remain as it is
speed2car
shall remain as it is";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}