# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d+\h+|\h+\d+$|(\h+\d+\h+)"
test_str = ("need 4 speed\n"
"shall become \"need speed\"\n\n"
"4 speed\n"
"shall become \"speed\"\n\n"
"speed 4\n"
"shall become \"speed\"\n\n"
"At the same time\n\n"
"4speed shall remain as it is\n\n"
"speed4\n"
"shall remain as it is\n\n"
"speed2car\n"
"shall remain as it is")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.