#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(\d)\b"
Local $sString = "1-05-2019" & @CRLF & _
"2-05-2019" & @CRLF & _
"15-05-2019" & @CRLF & _
"27-05-2019"
Local $sSubst = "0$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)