package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d)\b`)
var str = `1-05-2019
2-05-2019
15-05-2019
27-05-2019`
var substitution = "0$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}